Debian lenny 2.6.31.4 커널 컴파일

Submitted by frozenrain on Fri, 10/16/2009 - 12:45
Forums

데비안식 커널 컴파일에 대한 정보를 구글링을 통해 검색한 자료를 참고하여 커널의 업그레이드를 해봤습니다.
그러나 3번 모두 컴파일도중 에러메시지를 내면서 중단되어버리는군요. 에러메시지는 그냥 넘어가버렸군요...;;

구글링으로 검색한 문서를 보니 lenny 가 릴리즈되기 이전의 문서들입니다.
데비안 핸드북과 딱히 다른 점도 없는 내용이었습니다.
혹시, 컴파일 방법이 개선(?)되었다거나, 2.6.31 버전이 데비안식의 커널 컴파일이 불가능하거나 그런문제인지...
정 안되면 데비안식이 아니더라도 커널 컴파일을 감행할 생각중입니다.

지금 버전만 내려서 같은 방법으로 시도하고 있습니다. 또 에러가 발생한다면 에러메시지를 올려보겠습니다.
해결방법을 아시는분 한 수 가르침 부탁드립니다.

# cd /usr/src 
# tar vfxj linux-2.6.31.4.tar.bz2 
# ln -s linux-2.6.31.4 linux 
# cd linux # make menuconfig 
# make-kpkg --revision=6.31 --initrd binary-arch

 

wildapple

Submitted: Sat, 10/17/2009 - 12:54

Modified: Wed, 05/03/2017 - 15:29

저는 아무 이상 없이 만들어 지는군요.

* lenny 에
deb http://www.backports.org/debian lenny-backports main
를 추가해서 사용하는데 업그레이드된 파일이 있어서 일까요?